all posts

Python version 3.x.x is not supported by node-gyp error

Published to Blog on 13 May 2014

Problem: You try to npm install a node package on Windows and get an error similar to: Python version 3.x.x is not supported by node-gyp

Issue: You have Python 3.x installed and node-gyp needs version 2.7. You may already have 2.7 installed but your PATH var for python is pointing to the new one.

Fix: If you do not already have Python 2.7 installed then do so. Next find the path to that install and do the following: npm config set python C:\Python27\python.exe (using whatever your path to it is). Now you can go back and npm install the original package you were trying to install before getting the error.


Dan Hounshell
Web geek, nerd, amateur maker. Likes: apis, node, mobile, motorcycles, watches, food, Nashville, Savannah, Cincinnati and family. Dislikes: mean people
Dan Hounshell on Twitter